Úvodní stránka Excel(entní) taháky Vzorová data
 

Excel -- Duplicitní hodnoty -- Zpracování seznamu duplicitních hodnot 1

1. Identifikace duplicitních hodnot
  1. Sloupec A obsahuje data, která se v seznamu opakují.
  2. Přehled jedinečných hodnot můžeme vytvořit pomocí Rozšířeného filtru.


2. Určení počtu duplicit
  1. Do buňky B2 zapíšeme vzorec
    =INDEX(ČETNOSTI(POZVYHLEDAT($A$2:$A$20;$A$2:$A$20;0);POZVYHLEDAT($A$2:$A$20;$A$2:$A$20;0));ŘÁDEK()-1)
    který zkopírujeme směrem dolů až do buňky B20
  2. Vzorec vrací dva typy hodnot
    • - u prvního výskytu duplicity počet hodnot
    • - u dalších výskytů duplicity hodnotu 0



3. Určení jedinečných hodnot
  1. Jedinečné hodnoty v seznamu mají v odpovídající buňce sloupce B hodnotu 1.



4. Vytvoření přehledu unikátních hodnot
  1. Aktivujeme oblast buněk A1:B20 a pomocí Data > Seřadit seřadíme záznamy podle hodnoty vzorce.
  2. Buňky A1:B9 obsahují unikátní hodnoty (zástupce hodnot) s určením počtu výskytů těchto hodnot v seznamu.



5. Určení počtu unikátních hodnot
  1. Pokud potřebujeme zjistit počet unikátních hodnot, použijeme maticový vzorec =SUMA(1/COUNTIF(A2:A20;A2:A20)).
  2. Protože se jedná o vzorec maticový, potvrdíme jej stiskem kombinace kláves Ctrl+Shift+Enter. V řádku vzorců bude tento vzorec "uzavřen" do složených závorek, které Excel používá pro odlišení maticových vzorců od standardních.

    (Pokud se potřebujete seznámit s problematikou maticových vzorců, stáhněte si ExcelAsistentMagazín 03/2003)

  3. Hodnota 8 odpovídá 8 unikátním hodnotám v našem seznamu
    1. Citroen
    2. Opel
    3. Škoda
    4. Fiat
    5. Volvo
    6. BMW
    7. Mercedes
    8. Peugeot



6. Identifikace prvního výskytu hodnoty
  1. Pokud potřebujeme označit buňky, ve kterých se vyskytuje nová hodnota, zapíšeme do buňky B2 vzorec

    =N(COUNTIF($A$2:A2;A2)=1)

    a pak ho zkopírujeme do sloupce B.
  2. Vzorec vrací dva typy hodnot
    • - u prvního výskytu hodnoty číslici 1
    • - u dalších výskytů hodnot číslici 0
  3. Seznam můžeme opět seřadit pomocí Data > Seřadit a tak získat přehled unikátních hodnot.
  4. Tento přehled můžeme získat i využitím rozšířeného nebo automatického filtru

    Data > Filtr > Automatický filtr.



7. Identifikace prvního výskytu hodnoty pomocí podmíněného formátování
  1. Pokud potřebujeme označit buňky, ve kterých se vyskytuje nová hodnota, můžeme použít vzorec

    =N(COUNTIF($A$2:A2;A2)=1)

    jako kritérium podmíněného formátování.
  2. Označíme buňky obsahující seznam A2:A20
  3. Pomocí Formát > Podmíněné formátování aktivujeme dialogové okno určené k nastavení kritérií a formátovacích pravidel
  4. vzorec musíme upravit tak, aby vracel pravdivostní hodnotu PRAVDA nebo NEPRAVDA, což znamená, že jej rozšíříme na tvar

    =(N(COUNTIF($A$2:A2;A2)=1)=1)

  5. Nastavíme barvu písma na červenou


Úvodní stránka Excel(entní) taháky Vzorová data