Úvodní stránka Excel(entní) taháky Vzorová data
 

Excel -- Duplicitní hodnoty -- Zpracování seznamu duplicitních hodnot 2

1. Identifikace záznamů, které se vyskytují jen v jediném sloupci
  1. Sloupce A:B obsahují data, která se v seznamu opakují.
  2. Identifikovat počet záznamů, které jsou obsaženy v obou sloupcích, můžeme pomocí vzorce
    =POČET(POZVYHLEDAT(A1:A10;B1:B10;0)) .
  3. Pokud chceme vizuálně odlišit duplicitní a jedinečné položky, využijeme k tomu podmíněné formátování s kritériem
    =(COUNTIF($A$1:$B$10;B2)>1)


2. Identifikace duplicit v seznamu
  1. Cílem je v seznamu vizuálně odlišit jedinečné hodnoty a duplicity.
  2. V případě duplicit chceme odlišit první a následné hodnoty duplicit
    • - první výskyt duplicity označit žlutě
    • - další výskyt duplicity označit zeleně
  3. Identifikaci zajistíme pomocí podmíněného formátování s kritériem
    =KDYŽ(COUNTIF($A:$A;$A2)>1;COUNTIF($A$1:$A2;$A2)=1)
    a
    =KDYŽ(COUNTIF($A:$A;$A2)>1;COUNTIF($A$1:$A2;$A2)>1)
  4. (nejdříve vyznačíme celou oblast seznamu A2:A20 s aktivní buňkou A2, aktivujeme dialogové okno pro nastavení podmíněného formátování a vzorec zapíšeme)



3. Určení čísla řádku, který obsahuje 1. výskyt duplicitní hodnoty
  1. Často je užitečné určit nejenom počet unikátních nebo jednoznačných hodnot, ale důležité je i určení záznamu, který představuje první výskyt duplicity.
  2. U rozsáhlých záznamů je však velice užitečné určení čísla řádku, ve kterém se poprvé daná hodnota vyskytla.
  3. Tuto informaci můžeme získat pomocí vzorce
    =KDYŽ(COUNTIF($A$1:$A2;$A2)>1;POZVYHLEDAT($A2;$A$1:$A2;0);"")



4. Porovnání dvou seznamů s cílem vyloučit shodné položky.
  1. Buňky A2:B20 obsahují dva seznamy hodnot, které potřebujeme porovnat.
  2. Pomocí Vložit>Název>Definovat... označíme seznam ve sloupci A názvem seznam1 a seznam ve sloupci B označíme názvem seznam2.
  3. Do buňky D2 zapíšeme vzorec =KDYŽ(COUNTIF(seznam2;seznam1)=0;seznam1;"") a zkopírujeme ho do všech buněk oblasti D2:D20. Vzorec vrátí název položky, která se vyskytuje v seznamu1 a není obsažena v seznamu2.
  4. Do buňky E2 zapíšeme vzorec =KDYŽ(COUNTIF(seznam1;seznam2)=0;seznam2;"") a zkopírujeme ho do všech buněk oblasti E2:E20. Vzorec vrátí název položky, která se vyskytuje v seznamu2 a není obsažena v seznamu1.


Úvodní stránka Excel(entní) taháky Vzorová data